Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Wiped out cam after 1 year

  1. #11
    Join Date
    Feb 2014
    Location
    Ontario, Canada
    Posts
    346
    Either way, If I was YZPAUL i would run from that engine builder and not let him touch or choose another cam/lifter set for the engine he has built him!! I also don't use or add any ZDDP after break in. Any flavor of 10w30 on sale has been fine for my refreshed 350 flat tappet with about 20,000 new miles on it now.
    Jus' sayin
    Eric
    Eric & Christine

    http://73-77oldsmobile.freeforums.net/

    1976 Olds Cutlass Supreme
    2009 Pontiac G8 Black
    2009 Pontiac G8 liquid red
    2006 Pontiac GP Silver

  2. #12
    Join Date
    Mar 2012
    Location
    fort lauderdale
    Posts
    833
    Are you 12 year's old?....SVNT442?

  3. #13
    Join Date
    Sep 2017
    Location
    San Jose, CA
    Posts
    11
    Quote Originally Posted by riptide motorsport View Post
    Are you 12 year's old?....SVNT442?
    35 years ago..lol. It was a joke man...he he.

  4. #14
    Join Date
    Apr 2009
    Location
    Essexville, Michigan
    Posts
    120
    Quote Originally Posted by 76oldsman View Post
    Either way, If I was YZPAUL i would run from that engine builder and not let him touch or choose another cam/lifter set for the engine he has built him!! I also don't use or add any ZDDP after break in. Any flavor of 10w30 on sale has been fine for my refreshed 350 flat tappet with about 20,000 new miles on it now.
    Jus' sayin
    Eric
    I am in talks with cutlassefi for all the parts needed for a roller set-up Thanks for the advice

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •